Getting started

This section contains information and tasks for first-time AEN users.

In this getting started guide, you will:

1. Download the AEN cheat sheet

Before you start, download and print the AEN cheat sheet for easy reference.

2. Access your user home page

After your administrator has set up your server and new Anaconda account, you will receive a welcome email.

  1. Click the link in the email to open the AEN login page.

    NOTE: Use the domain name and not the IP address when you connect to AEN. Using the IP address can cause TLS and security certificate errors.

  2. Enter your AEN account username and password.

    NOTE: Some administrators allow you to create your own account. If your administrator has allowed this, in the create a new account section, create your own username and password.

  3. Click the Login button.

    Your user home page, where all good things happen, is displayed:

    ../../../_images/aen-user-index_profilescreen41.png

3. Create a new project

  1. There are 2 ways to create a new project in AEN:

    • On the right side of the AEN task bar, click on the New Project icon:

      ../../../_images/aen-user-projects_new1.png

    • On your home page, click the New project button:

      ../../../_images/aen-user-projects_new1b.png

  2. On the Project page that is displayed, type a name for your project, such as “Testing.”

    ../../../_images/aen-user-projects_new2.png

  3. Type a summary of the project so you can recognize it later.

  4. Select whether your project will be public or private.

  5. Verify that the default data center is selected.

    TIP: You can update the project summary and description at any time from the Project menu in the Project Settings. To return to your project at any time, click the project name.

  6. Click the Next button.

    Your new project’s home page is displayed:

    ../../../_images/aen-user-projects_created.png

  7. To change the project settings, click the Project Settings icon on at the top right.

    ../../../_images/aen-user-project_settings.png

  8. Modify the summary or add a description of the project.

    TIP: A project description is recommended, and may be written in Markdown syntax (plain text valid Markdown).

    To see how Markdown will be displayed, in the description area, click the Preview tab.

4. Add collaborators

You can add team members to your project as collaborators. Adding team members to your projects makes collaboration easy because they have full access to the project’s applications, files and services.

When you add team members, their home directory is mounted in the project. There is no need to download and email data or scripts—team members can work on the same files in the same environment in which you are working.

To add collaborators to your project:

  1. From your project home page, in the Team box, begin typing a teammate’s username.
  2. In the list that is displayed, select the teammate’s username.
  3. Click the Add button.
../../../_images/aen-user-projects_collaborators.png

  1. Repeat these steps for each team member you want to add as a collaborator.

TIP: You can add or remove team members any time from the Team menu in Project Settings. You can also modify a team member’s read, write or execute permissions at any time from the Using Workbench.

5a. Open an example notebook, OR

  1. From your project home page, click the Jupyter Notebooks icon.

  2. On the File View page, click the Examples folder.

    ../../../_images/aen-exnbs.png

  1. Select any of the example notebooks.
  2. To see the default results of the formulas used in the displayed notebook, in the Cell menu, select Run All.
  3. To experiment with changing the notebook, edit any of the formulas in the notebook.
  4. In the Cell menu, select Run All.

Any differences resulting from your edits are displayed.

5b. Create a new environment and notebook

If you are already familiar with creating notebooks, you can easily set up a new environment with the programs you need—like SciPy and NumPy—then open a new notebook and make your edits.

To create a new environment:

  1. From your project home page, click the Jupyter Notebooks icon.
  2. On the File View page, click the Conda tab.
  3. To add a new conda environment, on the top right of the Conda tab, click the + icon.
  4. Type a name for your environment.
  5. Select Python 2, Python 3 or R language kernel.
  6. Click the Create button.
  7. To activate your new environment, click its name.

The packages that are available and installed in your new environment are displayed.

Adding SciPy and Numpy packages

  1. In the available packages section, search for the package name numpy—all lower case.
  2. In the results section, next to numpy, select the checkbox.
../../../_images/aen-env-numpy.png

  1. Click the Install icon.
  2. To confirm your installation, click the Install button.

Numpy is displayed in the installed packages section—if not, click the Refresh button. Repeat these steps to install the Scipy package—searching for scipy in step 1.

TIP: You can return to this screen at any time to add additional packages to this environment.

Creating a new notebook in your environment

  1. From the AEN homepage, click the Files tab.

  2. On the top right of the Files tab, click the New button.

  3. Under Notebooks, select the Python environment with the name you entered while creating a new environment.

    ../../../_images/aen-env.png

NOTE: If you do not see your new environment listed under Notebooks, next to the New button, click the Refresh button.

A new locked notebook is displayed. Paste or write some code to execute when you are ready.

6. Create checkpoints for version control

Whether you are exploring an existing notebook, or creating a new one, you can easily create checkpoints, return to an earlier version, compare two different versions and save them for reference.

To create a checkpoint, in the File menu, select Save and Checkpoint:

../../../_images/aen-user-checkpoint.png

To revert your notebook to a previous checkpoint, in the File menu, select Revert to Checkpoint.

NOTE: For more information about revision control features, including creating commits and comparing differences, see Using the Revision Control Mechanism extension.

8. See what to do next

Now that you have completed the Getting Started guide, you are ready to move on to basic tasks and advanced tasks.